Requisitos

Para executar o WordPress, recomendamos que a sua hospedagem suporte:

  • Php versão7.4 ou superior.
  • Versão do MySQL 5.7 ou superior ou versão MariaDB 10.2 ou superior.
  • HTTPS Suporte

É mesmo isso. Recomendamos Apache ou Nginx como o servidor mais robusto e texto colaborativo cheio para executar o WordPress, mas qualquer servidor que suporta php e MySQL vai fazer. Dito isto, não podemos testar todos os ambientes possíveis e cada um dos anfitriões em nossa página de hospedagem suporta o acima e mais sem problemas.

Para recomendações detalhadas de extensão do PHP, consulte o Manual de Hospedagem.

Nota: Se você está utilizando um servidor onde só tem versões mais antigas do PHP ou MySQL, o WordPress também trabalha com o PHP 5.6.20+ e MySQL 5.0+, mas estas versões chegaram ao fim oficial da vida e, como tal, pode expor o seu site a vulnerabilidades de segurança.

Pergunte sobre isso

Aqui está uma carta que você pode enviar para o seu anfitrião; Copie e cole!

Estou interessado em executar o programa de código aberto WordPress <https://pt-ao.wordpress.org/> e gostaria de saber se a minha conta tem suporte ao seguinte:

  • PHP 7.4 ou superior
  • MySQL 5.7 ou maior OU MariaDB 10.2 ou melhor
  • Nginx ou Apache com módulo mod_rewrite
  • Suporte HTTPS

Obrigado!

Não é obrigatório, mas recomendado para melhor segurança

A hospedagem é mais segura quando aplicativos PHP, como o WordPress, são executados usando o nome de usuário da sua conta, em vez do nome de usuário compartilhado padrão do servidor. Pergunte ao seu host em potencial quais etapas eles tomam para garantir a segurança da sua conta.