WordPress 5.2.4 – Atualização de segurança

Já está disponivel a versão 5.3.4 do WordPress. Esta atualização de segurança corrige 6 problemas de segurança.

WordPress 5.2.4 já está disponível! Esta atualização de segurança corrige 6 problemas de segurança.

Estes erros afetam tanto o WordPress 5.2.3 quanto versões anteriores. A versão 5.2.4 os corrige e, portanto, você deve fazer a atualização.

Se você ainda não atualizou para a 5.2, também há versões atualizadas do WordPress 5.1 e anteriores que contêm as correções necessárias.

Atualizações de segurança

  • Agradecemos ao Evan Ricafort por encontrar um problema que permitia que XSS (execução de scripts de outros sites) armazenado fosse adicionado pelo Personalizar.
  • Agradecemos ao J.D. Grimes que encontrou e comunicou um método de ver posts não autenticados.
  • Agradecemos ao Weston Ruter por encontrar uma forma de armazenar XSS para injetar JavaScript em tags de estilo.
  • Agradecemos ao David Newman por destacar um método de contaminar o cache de solicitações GET de JSON pelo cabeçalho Vary: Origin.
  • Agradecemos ao Eugene Kolodenker que encontrou uma forma de falsificar uma solicitação feita pelo servidor na forma que os URLs são validadas.
  • Agradecemos ao Ben Bidner da equipe de segurança do WordPress que encontrou um problema relacionado à validação do referenciador no admin.

Agradecemos também a todos por comunicarem as vulnerabilidades privadamente, isso permitiu que tivéssemos tempo suficiente para fazer as correções antes que sites WordPress fossem atacados.

Para mais informações, navegue pela lista completa de alterações no Trac ou leia a página de documentação da versão 5.2.4.

O WordPress 5.2.4 foi uma versão de manutenção com ciclo de lançamento curto. O próximo grande lançamento será a versão 5.3.

Você pode baixar o WordPress 5.2.4 ou ir em Painel → Atualizações e clicar em Atualizar agora. Sites com suporte a atualizações automáticas em segundo plano já começaram a se atualizar.

Além dos pesquisadores de segurança mencionados acima, agradecemos também todas as pessoas que contribuíram para o WordPress 5.2.4:

Aaron D. CampbelldarthhexxDavid BinovecJonathan DesrosiersIan DunnJeff PaulNick DaughertyKonstantin ObenlandPeter WilsonSergey BiryukovStanimir StoyanovGarth MortensenvortfuWeston RuterJake Spurlock, e Alex Concha.

How the Angolan Community handles PTE Requests

Following the path of some other locales, here are the guidelines for all WordPress Devs who wish to have their products (themes, plugins) localized in Portuguese (pt_AO, Angola), to give it a wider chance to be adopted by Angolan users.

In order to assure the best possible quality for all translations (and therefore for the products you so dearly worked on), we have established a few rules to grant you PTE (Project Translator Editor) status for your product(s):

  1. If YOU want to become PTE, we follow the WordPress meta handbook for translations recommendations. We’ll not accept such a request if you don’t speak Portuguese.
  2. If you don’t speak Portuguese and will have a TRANSLATOR working on your product, please have them work on the WP translate platform
  3. You should all follow these steps (either YOU, the Dev, or the Translator):
  • Translate as a Contributor;
  • A PTE will review the translations;
  • A PTE or a GTE (General Translator Editor) will give you (or translator) the opportune feedback;
  • If the quality of the translation is up to the standards we all try to follow (remember, a poor translation is as bad for your product as it is for the entire WP ecosystem) You (or your translator) will be granted PTE authority.

WHY DO WE FOLLOW THESE GUIDELINES?

  • We strive at perfection: we aim at having the best possible localization for all products in the WordPress ecosystem. And that requires that all translations be done in the best possible way.
  • It helps us create a community of Angolan translators that know each other, and that can support each other when needed.
  • We think globally, and aim at consistency.
  • It streamlines and optimizes the process, reducing the amount of «unproper» translations and, by default, the time spent on rejecting and revising translations. (Thus allowing more time to be devoted to the actual localizing).

It is not undifferent as what happens on GitHub, where access is not given directly to original code, but allowed through Forks and Pull Requests (just to give you a metaphor that might be closer to your approach).

We do feel you can understand that these rules are meant to give You the best possible localization for your product(s), and to give the entire WordPress community a better UX, a stronger platform and a healthier ecosystem to work on.

We hope everything is clear. If not, you can always catch us on Slack to discuss this further. Happy coding!

WordPress 5.2 Beta 3 já está disponível!

WordPress 5.2 Beta 3 já está disponível!

Este software ainda está em desenvolvimento, por isso, não recomendamos que você o execute em um site de produção. Considere configurar um site de teste para jogar com a nova versão.

Existem duas maneiras de testar o mais recente beta do WordPress 5.2: experimente o plugin WordPress Beta Tester (você vai querer selecionar a opção “night edge nights”), ou você pode baixar a versão beta aqui (zip).

O WordPress 5.2 está previsto para ser lançado em 30 de abril , e precisamos da sua ajuda para chegar lá! Graças aos testes e feedback de todos que tentaram o beta 2 , quase 40 ingressos foram fechados desde então. Aqui estão as principais mudanças e correções de bugs:

  • O novo recurso de integridade do site continuou a ser refinado.
  • Plugins não são mais atualizados se um site estiver executando uma versão não suportada do PHP (veja #46613).
  • Agora é mais evidente quando um site está sendo executado no Recovery Mode (veja #46608).
  • O botão livre de distração não quebra mais a navegação do teclado no Editor Clássico (veja #46640).
  • As tecnologias de assistência fazem um trabalho melhor ao anunciar os submenus da barra de administração (ver #37513).
  • As linhas de assunto nos e-mails do WordPress são agora mais consistentes (ver #37940).
  • As exportações de dados pessoais agora só aparecem como concluídas quando um usuário faz o download de seus dados (ver # 44644).
  • Mais melhorias na acessibilidade (veja #35497 e #42853).

Atualização Mínima da Versão do PHP

Lembrete importante: no WordPress 5.2 beta 2, a versão mínima do PHP exigida pelo WordPress é 5.6.20. Se você estiver executando uma versão mais antiga do PHP, é altamente recomendável atualizá-lo agora, antes que o WordPress 5.2 seja lançado oficialmente.

Notas do desenvolvedor

O WordPress 5.2 tem muitos refinamentos para aprimorar a experiência do desenvolvedor. Para acompanhar, inscreva-se no blog Make WordPress Core e preste atenção especial às notas dos desenvolvedores quanto a atualizações sobre essas e outras alterações que possam afetar seus produtos.

Como ajudar

Você fala um idioma diferente do inglês? Ajude-nos a traduzir o WordPress para mais de 100 idiomas! A versão beta 3 também marca o ponto de congelamento de string flexível do cronograma de lançamento 5.2.

Se você acha que encontrou um bug , pode postar na área Alfa / Beta nos fóruns de suporte. Nós adoraríamos ouvir de você! Se você estiver confortável a escrever um relatório de como reproduzir erro, registre um no WordPress Trac , onde você também pode encontrar uma lista de bugs conhecidos .


Você olharia para o fato de que 
cada dia traz um 
teste de lançamento mais próximo para estar pronto
 .

Luanda WordPress Meetup

WordPress Para Iniciantes

Você está procurando fazer um site? Começar um site pode ser um pensamento aterrorizante, especialmente quando você não se ache  inteligente. Finalmente existe  uma maneira simples de criar belos sites e seguros – O WordPress.

Se quiser aprender a dar os primeiros passos para criar um site WordPress, junte-se ao Luanda WordPress Meetup . 

Esta aberto pra todo e de forma  gratuita. Traz consigo seu computador  se for possível.

O Luanda WordPress Meetup acontecerá em Luanda/Coqueiros (Prédio da totó-bola, 7.º andar).


Guia Meetup

Se você deseja iniciar um Meetup em sua cidade ou saber mais , criamos um guia para você !

Outras maneiras de contribuir para o WordPress em Angola

Se você também tem uma grande paixão pelo WordPress, participe de um Meetup, contribua com as traduções.

WordPress 5.2 Beta 2

WordPress 5.2 Beta 2 já está disponível!

Este software ainda está em desenvolvimento, então nós não recomendamos você executá-lo em um site em produção. Considerar a criação de um site de teste para jogar com a nova versão.

Há duas maneiras de testar o WordPress 5.2 beta: tente com o plugin WordPress Beta Tester  (você vai selecionar a “bleeding edge nightlies”), ou você pode baixar a versão beta aqui (zip).

WordPress 5.2 está programado para lançamento em 30 de abril, e nós precisamos de sua ajuda para chegar lá! Graças a testes e feedback de todos que testaram beta 1, cerca de 100 ingressos foram fechadas desde então. Aqui estão as principais mudanças e correções de bugs:

  • Adicionamos suporte para Emoji 12! 🪂
  • Uma novíssima template tag, wp_body_open(), (e uma ação wp_body_open correspondente) permitirá que temas e plugins adicionem conteúdo logo depois da abertura da tag <body>(#12563).
  • Tags de parágrafo desnecessárias deixaram de aparecer no conteúdo dinâmico dos blocos (#45495).
  • As telas do Diagnóstico receberam várias correções, ajustes e melhorias de desempenho.
  • A proteção contra travamentos deixou de interromper a edição de plugins (#46045).
  • O tratamento personalizado de erros agora carrega corretamente (#46069).

Actualização mínima da versão PHP

A partir de WordPress 5.2 beta 2, a versão PHP mínima que o WordPress vai exigir é 5,6,20. Se você está executando uma versão mais antiga do PHP, recomendamos atualizá-lo agora, antes do WordPress 5.2 ser oficialmente lançado.

Notas do desenvolvedor

O WordPress 5.2 tem várias pequenas melhorias para melhorar a experiência de desenvolvimento. Para manter-se atualizado, assine o blog Make WordPress Core com especial atenção para as notas para desenvolvedores, que trazem atualizações sobre essas e outras mudanças que podem afetar seus produtos.

Como Ajudar

Você fala outro idioma que não é o inglês? Ajuda-nos a traduzir o WordPress em mais de 100 idiomas!

Se você achar que encontrou um bug, você pode postar para o Alfa/Beta área nos fóruns de suporte. Nós adoraríamos ouvir-te! Se você está confortável a escrever um relatório de como reproduzir erro, envie para o Trac do WordPress, onde também é possível encontrar uma lista de erros conhecidos.


A coisa boa
sobre betas, é que betas
são uma coisa boa.
🐯

Atualização da versão mínima do PHP

WordPress 5.2 é esta previsto para lançamento no final deste mês, e com ele vem uma atualização para a versão mínima necessária de PHP. WordPress agora vai exigir um mínimo de PHP 5.6.20.

A partir do WordPress 5.1, os usuários que executam versões do PHP abaixo de 5.6 tiveram uma notificação em seu painel que inclui informações para ajudá-los a atualizar o PHP . Desde então, as estatísticas do WordPress mostraram um aumento nos usuários em versões mais recentes do PHP.


Widget que os usuários veem no Painel ao usar versões antigas do PHP

Por que você deve atualizar o PHP

Se o seu site estiver sendo executado em uma versão não suportada do PHP, o atualizador do WordPress não oferecerá o WordPress 5.2 ao seu site. Se você tentar atualizar o WordPress manualmente, essa atualização falhará. Para continuar usando os recursos mais recentes do WordPress, você deve atualizar para uma versão mais nova do PHP.

Ao atualizar para uma nova versão do PHP, o WordPress encoraja a atualização para sua versão recomendada, o PHP 7.3. A equipe interna de PHP fez um ótimo trabalho, tornando sua versão mais recente a versão mais rápida do PHP. Isso significa que a atualização melhorará a velocidade do seu site, tanto para você quanto para seus visitantes.

Esse aumento de desempenho também significa menos menos recursos de servidores são necessários para hospedar sites. Atualizando o PHP não é apenas bom para o seu site, também significa menos energia é necessária para o 1-em-3 sites que usam o WordPress , por isso é bom para o planeta.

Como atualizar o PHP

Se você precisar de ajuda para atualizar para uma nova versão do PHP, a documentação detalhada está disponível . Isso inclui comunicação de amostra para enviar à sua empresa de hospedagem para que eles o ajudem. Muitas empresas de hospedagem publicaram informações sobre como atualizar o PHP que é específico para elas.

5.6 agora, 7+ em breve

Este é o primeiro aumento na versão necessária do PHP para WordPress desde 2010, mas pode não ser o único aumento em 2019. A equipe principal do WordPress irá monitorar a adoção das versões mais recentes do PHP com o objetivo de tornar o PHP 7+ a versão mínima no final do ano.

Tradução da versão 5.1.1 já está disponível para pt_AO!!!

Com uma ajuda da comunidade portuguesa, finalmente já esta disponível O WordPress 5.1.1 totalmente traduzido. Para quem nunca antes possuía uma tradução oficial  é um enorme momento histórico. O desafio continua, e temos muito trabalho pela frente…

Um terço da Web

O WordPress é a maior  ferramenta, fácil e flexível  de código aberto desenvolvido em php para criação de sites. Com 33,4% dos sites na web, o WordPress vem se tornando o sistema de gerenciamento de conteúdos, sites e blogs mais poderoso na web controlando 1/3 dos 10 milhões de sites existente.

Muitos sites de grandes empresas são construídos usando o WordPress, bem como  blogs de celebridades, portais de noticias.

Segundo Joost de Walk “O caminho aqui tem sido muito emocionante. Em 2005, estávamos comemorando 50.000 downloads . Seis anos depois, em janeiro de 2011, o WordPress estava alimentando 13,1% dos sites. E agora, no início de 2019, estamos acionando 33,4% dos sites. Nosso último lançamento já foi baixado cerca de 14 milhões de vezes e só foi lançado no dia 21 de fevereiro.”