WooCommerce Legacy REST API

Descrição

The Legacy REST API will no longer part of WooCommerce as of version 9.0. This plugin restores the full functionality of the removed Legacy REST API code in WooCommerce 9.0 and later versions.

For all intents and purposes, having this plugin installed and active in WooCommerce 9.0 and newer versions is equivalent to enabling the Legacy REST API in WooCommerce 8.9 and older versions (via WooCommerce – Settings – Advanced – Legacy API). All the endpoints work the same way, and existing user keys also continue working.

On the other hand, installing this plugin together with WooCommerce 8.9 or an older version is safe: the plugin detects that the Legacy REST API is still part of WooCommerce and doesn’t initialize itself as to not interfere with the built-in code.

Please note that the Legacy REST API is not compatible with High-Performance Order Storage. Upgrading the code that relies on the Legacy REST API to use the current WooCommerce REST API instead is highly recommended.

Instalação

Simply install and activate the plugin. In WooCommerce 8.9 and earlier nothing will change. Starting with WooCommerce 9.0 having the plugin installed will provide the full functionality of the Legacy REST API.

Note that since the Legacy REST API is not compatible with HPOS, once the plugin is active you will see a “WooCommerce has detected that some of your active plugins are incompatible with currently enabled WooCommerce features” notice in your WordPress admin area.

Avaliações

21 de Maio, 2024
Update : After updating Woocommerce to 8.9.1 this plugin was installed automatically again (v 1.0.4) and is now working without a crash. Version 1.0.3: Critical error on line 77 when updated. Had to follow the safe mode to disable this plugin and temporary delete it. Theme used: Astra. After deleting the Rest API plugin everything went back to normal. Please fix.
16 de Maio, 2024
did not download or request this plugin and it can’t be deleted or deactivated. had to delete it in cPanel
15 de Maio, 2024
Even though Rest API was unticked on our site – as in not used, non-required – and there are no webhooks,this new replacement plugin was installed by WooCommerce anyway – it was bad enough when Woo began saying certain plugins were suddenly compulsory- but I did not realize they would just install plugins without consent. We have had problems since the latest Woo update so it is hard to say if the inability of would-be buyers to add products to cart is due to this plugin or another revenue-draining update from WooCommerce. However, I am giving it one star because it is unneccessary, not required and was added as a live, active plugin by WooCommerce, when Rest API itself was not active.
Leia todas as 22 avaliações

Contribuidores e desenvolvedores

“WooCommerce Legacy REST API” é um software com código aberto. As seguintes pessoas contribuíram para este plugin.

Contribuidores

“WooCommerce Legacy REST API” foi traduzido para 3 localidades. Obrigado aos tradutores por suas contribuições.

Traduzir “WooCommerce Legacy REST API” para o seu idioma.

Interessado no desenvolvimento?

Navegue pelo código, dê uma olhada no repositório SVN ou assine o registro de desenvolvimento via RSS.

Registro de alterações

1.0.0 2023-11-01

First version, replicates the WooCommerce Legacy REST API v3.1.0 present in WooCommerce 8.3.

1.0.1 2024-01-08

  • Replace the text domain for human-readable strings from ‘woocommerce’ to ‘woocommerce-legacy-rest-api’.
  • Add sanitization for data received via query string arguments and the $_SERVER array.

1.0.2 2024-05-01

  • Add a dismissable admin notice indicating that the Legacy REST API is not compatible with HPOS.
  • The notice will appear if the orders table is (or has been) selected as the orders data store in the WooCommerce features settings page, and will disappear when that ceases to be true. Once the notice is dismissed it will never appear again.

1.0.3 2024-05-15

  • Fix a bug introduced in 1.0.2 that caused a fatal error when checking if HPOS is enabled.

1.0.4 2024-05-16

  • Correct a problem in which the attempted removal of admin notices (warning of HPOS incompatibility) could lead to a fatal error during plugin deactivation.