WPSSO WP Sitemaps XML

Descrição

Manage which post and taxonomy types are included in the WordPress sitemaps XML.

Exclude posts, pages, custom post types, taxonomy terms (categories, tags, etc.), and user profiles marked as “No Index”.

Automatically enhance the built-in WordPress sitemaps XML with article modification times.

The WP Sitemaps Settings Page

The WP Sitemaps settings page allows you to choose which post and taxonomy types are included in the WordPress sitemaps XML.

The Document SSO Metabox

When editing a post, page, custom post type, taxonomy term (category, tag, etc.), or user profile page, you can enable the “No Index” option under the Document SSO > Edit Visibility tab to exclude that webpage from the WordPress sitemaps XML.

WPSSO Core Required

WPSSO WP Sitemaps XML (WPSSO WPSM) is an add-on for the WPSSO Core plugin.

Imagens de tela

  • The WPSSO WPSM settings page offers options to customize the post and taxonomy types included in the WordPress sitemaps XML.
  • The No Index option under the Document SSO > Edit Visibility tab can be used to exclude individual posts, pages, custom post types, taxonomy terms, or user profile pages from the WordPress sitemaps XML.

Avaliações

There are no reviews for this plugin.

Contribuidores e desenvolvedores

“WPSSO WP Sitemaps XML” é um software com código aberto. As seguintes pessoas contribuíram para este plugin.

Contribuidores

“WPSSO WP Sitemaps XML” foi traduzido para 2 localidades. Obrigado aos tradutores por suas contribuições.

Traduzir “WPSSO WP Sitemaps XML” para o seu idioma.

Interessado no desenvolvimento?

Navegue pelo código, dê uma olhada no repositório SVN ou assine o registro de desenvolvimento via RSS.

Registro de alterações

Version Numbering

Version components: {major}.{minor}.{bugfix}[-{stage}.{level}]

  • {major} = Major structural code changes / re-writes or incompatible API changes.
  • {minor} = New functionality was added or improved in a backwards-compatible manner.
  • {bugfix} = Backwards-compatible bug fixes or small improvements.
  • {stage}.{level} = Pre-production release: dev < a (alpha) < b (beta) < rc (release candidate).

Standard Edition Repositories

Development Version Updates

WPSSO Core Premium customers have access to development, alpha, beta, and release candidate version updates:

Under the SSO > Update Manager settings page, select the “Development and Up” (for example) version filter for the WPSSO Core plugin and/or its add-ons. Save the plugin settings and click the “Check for Plugin Updates” button to fetch the latest version information. When new development versions are available, they will automatically appear under your WordPress Dashboard > Updates page. You can always reselect the “Stable / Production” version filter at any time to reinstall the latest stable version.

Changelog / Release Notes

Version 1.2.0 (2022/01/19)

  • New Features
    • None.
  • Improvements
    • None.
  • Bugfixes
    • None.
  • Developer Notes
    • Renamed the lib/abstracts/ folder to lib/abstract/.
    • Renamed the SucomAddOn class to SucomAbstractAddOn.
    • Renamed the WpssoAddOn class to WpssoAbstractAddOn.
    • Renamed the WpssoWpMeta class to WpssoAbstractWpMeta.
  • Requires At Least
    • PHP v7.2.
    • WordPress v5.5.
    • WPSSO Core v9.14.0.

Version 1.1.0 (2022/01/06)

  • New Features
    • None.
  • Improvements
    • Added support for the new WpssoOpenGraph->get_mod_og_type_id() method in WPSSO Core v9.13.0.
  • Bugfixes
    • None.
  • Developer Notes
    • None.
  • Requires At Least
    • PHP v7.2.
    • WordPress v5.5.
    • WPSSO Core v9.13.0.

Version 1.0.1 (2021/11/17)

  • New Features
    • None.
  • Improvements
    • None.
  • Bugfixes
    • Removed a ‘WPSSO_PLUGINDIR’ dependency check before loading the WpssoWpsmSitemaps class.
  • Developer Notes
    • None.
  • Requires At Least
    • PHP v7.2.
    • WordPress v5.5.
    • WPSSO Core v9.8.0.

Version 1.0.0 (2021/11/16)

  • New Features
    • Initial release.
  • Improvements
    • None.
  • Bugfixes
    • None.
  • Developer Notes
    • None.
  • Requires At Least
    • PHP v7.2.
    • WordPress v5.5.
    • WPSSO Core v9.8.0.